Unable to make call via Media API

Hi @budd.renaud,
Hope you are doing well.

Need your help for make call API.
I tried to make call using media API but i am always getting 504 timeout error.

    "name": "TimeoutError",
    "message": "Timeout error occured: Request failed to complete"

tried with all the possible params as per the doc on https://developer.mitel.io and in postman
mentioned for this API but it always returns with 504 error.


    "from": "150002",
    "to": "150003"

Could you please suggest what is wrong i am doing here.

Thanks in advance

Hi @singhcha !

First, are you using that exact URL? You should just use POST https://media.api.mitel.io/2017-09-01/endpoints/150002/calls. The previous versions of the Postman library were pointed to the dev cloud instead of public, so make sure you’re not pointed to the dev cloud unless that’s where your account actually resides.

Second, you don’t need to provide the ‘from’ parameter in this case since that’s already been determined by the path parameters (endpointId). I know it’s not completely clear in the docs.

Finally, make sure that your CloudLink Gateway is showing as connected and is syncing properly without any errors.

Yes @budd.renaud i am using the same exact url.
https://authentication.dev.api.mitel.io/2017-09-01/token for authentication token and https://media.eu-west-1.eu.dev.api.mitel.io/2017-09-01/endpoints/150002/calls for make call

I tried with the dev url but account is not there configured. Also i tried with cloudlink sdk @mitel/cloudlink-sdk": “0.1.0-alpha.141” i am getting the same error there as well. Notification and authorization apis are working fine from both with sdk and postman API. Just the make call is not working and error is the same from both the ways.

I’m a bit confused. You say you used the URL’s with ‘dev’ in them, but your account isn’t configured in dev?

Regardless, best practice is to avoid pointing directly to a regional cloud. Always use https://{{service}}.api.mitel.io (e.g. https://media.api.mitel.io) and you will be routed automatically to the right cloud based on your account.

I normally cannot speak to the SDK as that’s currently a strictly internal Mitel SDK (and not part of the API Program). That said, I understand there is an open issue with the ‘make call’ functionality of the SDK that is currently being investigated.

Can you share a screenshot of your API call in Postman? Feel free to direct message me if you don’t want the information public.

Hi Budd,

Are there still problems with the make call? Note I have only just setup the cloudlink gw for MiVB. For me it does actually make the call, which is odd, but I too get the 504 gateway timeout error back. Could be a red herring but in the gateway logs it looks like the cti server is failing to set a monitor on my device. Is there anything obvious that I could be missing here?

Hi Julian - I don’t think we ever finished troubleshooting and closed the loop on this. As far as I know there are no reported issues with the basic ‘Make Call’ API call, just with how it’s being used in other areas (e.g. the SDK). I will reach out to your internally.